Chat with us, powered by LiveChat Skip to content

Kvaser Mini PCI Express HS v2

SKU #: KV-01038-3
Save 9%
Original price $450
Current price $410

The Kvaser Mini PCI Express HS v2 is a small (30 x 51mm), yet advanced, real time CAN interface that adds one high speed CAN or CAN FD channel to any standard computer with mini PCI Express capability. PC communication is over the PCI Express system bus, making for extremely low latency with a time stamp accuracy of 1 µs. (Also available in a dual-channel version.)

  • Fully compliant to the PCIe bus specification 1.2, Type F2 form factor (Full-Mini with bottom-side keep outs).
  • High-speed CAN connection (compliant with ISO 11898-2), supporting a bit rate from 50 to 1000 kbit/s for Classical CAN and up to 8Mbit/s for CAN FD.
  • High transmission rate of up to 20000 messages/s.
  • Time stamp accuracy of 1 µs.
  • Galvanic isolation.
  • Suitable for industrial environments.
  • Low profile mini PCI Express-compliant 4-pin Molex connector provides CAN channel access.
  • Includes Molex to DSUB9 cable adapter.
  • Complies with EN 61000-6-2:2005, specifying EMC immunity for industrial environments.
  • Operates over the industrial temperature range of -40 to +85°C.
  • Kvaser’s free of charge CANLIB SDK can be used to develop software for the Mini PCI Express HS
  • board. Windows DLL library and examples included.
  • Supports Windows Vista or later.
  • Linux drivers and a dedicated SDK are available as a separate download.
  • Support for SocketCAN, see elinux.org for details.
  • Extended operating temperature range from -40 to 85 °C.
Property Value
The information herein is subject to change without notice.
Galvanic Isolation Yes
Bitrate 50-8000 kbit/s
Silent mode Yes
Error frame generation Yes
Error frame detection Yes
Weight 5 grams
Timestamp resolution 1 μs
On board buffer N/A
Maximum message rate, send 20000
Maximum message rate, receive 20000
Sound No
Clock synchronization N/A
Temperature range -40°C to +85°C
Dimensions (WxLxH) 30x51x5mm
Datasheet
Kvaser Mini PCI Express HS v2 Datasheet
Kvaser Mini PCI Express HS v2 User's Guide
Kvaser Mini PCI Express HS v2 User's Guide
Version V2.4.210216
Python module
The Canlib module is a Python wrapper for Kvaser CANlib SDK.
Version V1.17.748
Kvaser CANlib SDK
Software development kit - everything you need to develop software for the Kvaser CAN and LIN interfaces. Libraries, header files, sample programs for e.g. C, C++, C#, Visual Basic and Delphi, documentation, and more. Note: you need to download and install the appropriate device drivers separately.
Version V5.35.477
Kvaser SocketCAN Device Drivers
Kvaser SocketCAN Drivers for Linux.
Version V1.7.153
Kvaser DIADEM Driver
This free driver for National Instrument's DIAdem supports all CAN hardware from Kvaser.
Version V4.1.0
Kvaser Drivers for Windows
Windows drivers for all our CAN hardware. Please check release notes for information on which Windows versions are supported. It also contain a driver for the virtual CAN bus.
Version V5.35.477
Kvaser CANKing
A free of charge general-purpose CAN bus momnitor. Works with all CAN interfaces from Kvaser. Windows 200 and later recommended.
Version V6.18.106
Kvaser LabView VI Library for CAN
Library for National Instrument's LabView version for all Kvaser CAN hardware.
Version V19.3.0
Kvaser Linux Driver and SDK
Linux driver and SDK for Kvaser PCIcan/PCIcanx, Kvaser PCIcanII, Kvaser PC104+, Kvaser PCIcanx II, Kvaser USBcan II, Kvaser Memorator*, Kvaser Leaf family, Kvaser Memorator Pro**, Kvaser USBcan Pro and VirtualCAN. For LAPcan and LAPcan II, you should use version 4.2 of the driver. (*) only with USBcanII functionality, (**) only with USBcan Pro functionality
Version V5.35.477
Remove old drivers
Driver removal program. This program will remove the CAN driver (version 3.2 or older) from your computer. This is a version intended for those who have installed CANLIB 3.2 or older. Use it only if you need to remove an old version of the driver from your computer. Contact technical support if you have any questions.
Version 3.9c
Cleanup
Driver removal program. This program will remove the CAN driver (version 3.9 or older) from your computer. This program will not work with driver 4.0 or later. Use it only if you need to remove an old version of the driver from your computer.
Version 3.9c